Promethean ActivInspire unter Ubuntu 16.04 x86_64 nutzen

Interaktive Whiteboards sind schon eine Erfindung, die tatsächlich die Unterrichtsmethoden revolutionieren konnten und können. Vorausgesetzt der/die Unterrichtende sind in der Lage, damit erfolgreich und konsequent umzugehen. Eine Grundvoraussetzung für den glücklichen Umgang damit ist ein Stück Software, welche sich der Benutzung verschrieben hat. Open Sankoré ist da ein gutes Beispiel, hat aber auch einige Schwächen insbesondere in der Kompatibilität zur Verwendung von proprietären Dateiformaten für den Lehrmaterialaustausch. Deshalb kommt auch in meinen Unterrichtsszenarien vornehmlich die Software ActivInspire von Promethean zu Wort, obgleich ich kein Whiteboard besitze. Sei’s drum, die Preisfrage lautet dabei zunächst: Wie installiere ich die Software? Promethean selbst gibt dafür ein schickes (sogar lokalisiertes) Tutorial auf der Homepage preis, doch beziehen sich die Informationen noch auf Ubuntu 14.04 in einer 32bit (i386) Variante. Das nervt, denn de facto führe nich nur ich alle aktuellen Installation in 64 bit durch, und natürlich mit der aktuellsten LTS von Ubuntu 16.04.

Nach dieser Anleitung ist dann eine Installation auch hier möglich – danke an die französischssprachige Ubuntu-Community:

  1. 32bit-Architektur aktivieren:
    dpkg --add-architecture i386
    apt-get update
    apt-get dist-upgrade
  2. Eine alte libssl hier herunterladen und via Software Center installieren.
  3. Schlüssel vertrauen, Paketquellen hinzufügen, diese aktualisieren und activinspire in 32bit-Version installieren:
    wget http://activsoftware.co.uk/linux/repos/Promethean.asc | apt-key add - 
    echo deb http://activsoftware.co.uk/linux/repos/ubuntu trusty oss non-oss | tee /etc/apt/sources.list.d/promethean.list 
    apt-get update 
    apt-get install activinspire:i386
  4. ActivInspire via Befehl “/usr/local/bin/inspire” im Terminal starten und checken, ob noch Kompatibilitätsprobleme bestehen. Fehlen Bibliotheken, diese schlicht via “apt install $name:i386” ($name steht für den Installationsnanmen der fehlenden Software) nachinstallieren und Software starten.

Vorsicht: nicht nur führt das aktivieren der 32bit-Architektur möglicherweise zu Problemen, auch die Installation der veralteten und unsicheren (!) libssl-Bibliothek reißt ein meilenweites Sicherheitsloch in die Umgebung. Schließlich ist auch das Aktivieren von Fremdquellen von Promethean mit Vorsicht zu bedenken. Aber oftmals gilt nur, dass Pragmatismus siegt. Ich wollte lediglich darauf hinweisen ;c)

Xiaomi Redmi 1s/Hongmi 1s unter Ubuntu Linux als USB Geräte ansprechen

Das Xiaomi Hongmi 1s ist nicht gerade das günstigste chinesische Android Smartphone für 150,-€, doch bietet es preis-leistungs-technisch ein sehr hohes Niveau und von Werk aus die Android-Modifikation MIUI V5. Muss man nicht mögen (bei mir läuft seit dem ersten Tag CyanogenMod 11), ist jedoch bezüglich Rechteverwaltung gegenüber dem standard Android um Längen voraus.

Wie dem auch sei, ich habe mich für das Gerät entschieden und bin bislang wirklich zufrieden, hatte vorher auch ein anderes Mediatek basiertes Gerät aus China, welches mich nach 11 Monaten schwer im Stich gelassen hat. Aber es soll hier keine Werbung stattfinden, sondern dem Umstand Rechnung getragen werden, dass mein Ubuntu 14.04 das Hongmi 1s nicht ab Werk erkennt, wenn ich es anstecke – Windows 7 hingegen ohne Probleme. Das wurmt, hat jedoch einfache Gründe. Diese zu erklären dauert zu lange, daher schlicht eine einfache Lösung:

Wie im MIUI-Forum geschrieben reicht es unter Ubuntu 14.04 in der Datei /lib/udev/rules.d/69-libmtp.rules als root folgende Zeilen kurz vor Ende einzufügen. Ich habe sie bereits editiert, denn die im Eingangsposting angeführten Codelinien sind nicht für das Dateiformat angepasst, doch Posting #4 hat das freundlicherweise (für das 3W) übernommen.

# Xiaomi Redmi1S WCDMA – MTP Mode
ATTR{idVendor}==”2717″, ATTR{idProduct}==”1260″, SYMLINK+=”libmtp-%k”, MODE=”660″, GROUP=”audio”, ENV{ID_MTP_DEVICE}=”1″, ENV{ID_MEDIA_PLAYER}=”1″
# Xiaomi Redmi1S WCDMA – MTP Mode with USB Debug
ATTR{idVendor}==”2717″, ATTR{idProduct}==”1268″, SYMLINK+=”libmtp-%k”, MODE=”660″, GROUP=”audio”, ENV{ID_MTP_DEVICE}=”1″, ENV{ID_MEDIA_PLAYER}=”1″

Anschließend udev via “sudo service udev restart” neu starten und das Gerät wird anstandslos erkannt.

Fatal error: Failed to load steamui.so unter Ubuntu 14.04

Da ist man als aufgeschlossener Linuxer auch gleich im Beta Release Channel von Steam, da zerschießt ein Update mal den gesamten Client, welcher sich fortan nur noch dazu hinreißen lässt, die steamui.so-Bibliothek zu forden. Das Problem gibt es auch unter Windows (steamui.dll) und tritt häufiger bei Updates oder Grafikkarten/Treiberproblemen auf. Doch welcher Weg ist nun der, der letztlich zur Lösung führt und den geringsten Aufwan bedeutet?

Für mich dieser: Einfach wie die Jungs aus dem Steamforum angeben folgenden Befehl in die Konsole eingeben, um Steam zu starten.

STEAM_RUNTIME=1 steam

Hiernach sollte sich der Client starten, die Updates abbrechen und auf den Ausgangszustand zurückgehen. Hat bei mir funktioniert, auch wenn andere Nutzer berichten, dass das Löschen der Betaupdates aus

rm ~/.steam/steam/package/beta

ebenso helfen soll.

Ubuntu 12.04 auf non PAE Hardware wie Pentium/Celeron M Prozessoren nutzen

Wer noch ältere Notebooks herumliegen hat, welche einfach zu schade zum entsorgen sind, da sie grundsätzlich noch funktionieren, allerdings um die Sicherheit seines Systems aufgrund des auslaufenden Windows-XP-Supports besorgt ist (der 08. April 2014 ist nahe!), der findet vornehmlich im Linuxumfeld einen Ersatz. Viele Ratgeber und Magazine, darunter Heise, Cnet etc. empfehlen dann schnell Ubuntu 12.04, welches noch bis 2017 mit Sicherheitsupdates versorgt wird. Allerdings bootet dieses grundsätzlich nicht von Hardware, die kein PAE unterstützt (Physical Address Extension = die Möglichkeit für 32-Bit-Prozessoren, bis zu 64 GB an Ram zuzuweisen; alle Prozessoren nach 1995 sollten dies tun) oder fehlende Unterstützung vorgaukelt (besagte Intelprozessoren aus den Jahren 2003/2004 = Banias und Dothan Prozessoren).

Natürlich kann man sich nun eine Heftbeilage ergattern und gleich noch ein interessantes Magazin mit erwerben, doch ist das nicht unbedingt nötig, bietet bspw. Ubuntu doch von Haus aus bereits Möglichkeiten, auf den alten Kisten zu booten: Abhilfe schafft hierbei das nur rund 27 Mb große Mini- bzw. Netinstall-Image von Ubuntu 12.04, welches derzeit Ubuntu 12.04.4 installiert (also die stabile Version aus dem April 2012 inklusive aller Aktualisierungen). Internetverbindung vorausgesetzt kann man sich so sein eigenes System mittels grafischer Oberfläche im Terminal realisieren und lädt gleich die neuesten Pakete herunter. Und hinterher klappt es dann auch mit dem Booten in das noch einige Jahre sichere Ubuntu 12.04.

Übrigens gibt es auch noch viele andere Möglichkeiten, die Installation durchzuführen, wie in der Ubuntu-Dokumentation festgehalten. Der obige scheint mir jedoch der einfachste mit dem geringsten Aufwand zu sein. Wer noch etwas warten will, der kann auch der Veröffentlichung von Ubuntu 14.04 harren und sich mit Freigabe dieser LTS-Version mit Sicherheitsupdates bis 2019 auf eine der leichtgewichtigen Varianten wie Lubuntu und Xubuntu konzentrieren, die im Gegensatz zur Version aus 2012 auch die fünf jährige Unterstützung erhalten. Eine Hilfestellung für die Installation auf non-PAE Hardware findet sich ebenfalls in der Ubuntu-Hilfe. Natürlich ist es genauso möglich von der 12.04 auf die 14.04 mit einem Upgrade zu gelangen.

Privacy Policy Settings

Datenschutz DSGVO
Klick